본문 바로가기
[C++] 알고리즘 교육/20.그래프알고리즘

[알고리즘 20.1.1] 그래프 - 최단거리

by 안산학생 2019. 8. 12.

문제


그래프와 출발점, 도착점이 주어질 때 출발점에서 도착점까지 이동하기 위한 최단거리를 출력하는 프로그램을 작성하시오. 예를 들어, 아래 그림에서 출발 정점이 0, 도착 정점이 10이라고 할 때, 최단거리는 3이다.

 

입력


첫째 줄에 정점의 개수 N과 간선의 개수 M이 주어진다. ( 1 ≤ N ≤ 10,000, 1 ≤ M ≤ 1,000,000 ) 둘째 줄부터 간선의 정보가 주어진다. 각 줄은 두 개의 숫자 a, b로 이루어져 있으며, 이는 정점 a와 정점 b가 연결되어 있다는 의미이다. M+1 번째 줄에 대하여 출발점과 도착점의 정점 번호가 주어진다.

 

출력


출발점에서 도착점까지 이동하기 위한 최단거리를 출력한다.

 

예제 입력

11 14
0 1
0 2
1 2
1 4
1 5
2 3
3 7
4 7
4 9
4 10
5 6
6 8
6 10
7 8
0 10

예제 출력

3

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
#include<iostream>
#include<vector>
#include<queue>
 
using namespace std;
 
const int MAX = 1000005;
const int nMAX = 10005;
vector <int> graph[MAX];
int arr[nMAX] = {0,};
 
queue <int> q;
 
int n, m;
 
int flag = 0;
void BFS(){
  if(q.empty()) return;
  
  int node = q.front();
  q.pop();
  
  for(int i=0; i<graph[node].size(); i++){
    if(arr[graph[node][i]] == 0){
      q.push(graph[node][i]);
      arr[graph[node][i]] = arr[node]+1;
    }
  }
  
  if(!q.empty()) BFS();
}
 
int main(){
  int a,b;
  
  cin>>n>>m;
  
  for(int i=0; i<m; i++){
    cin>>a>>b;
    graph[a].push_back(b);
    graph[b].push_back(a);
  }
  
  int start, end2;
  cin>>start>>end2;
  
  q.push(start);
  arr[start] = 0;
  
  BFS();
  
  cout<<arr[end2];
  
  return 0;
}
http://colorscripter.com/info#e" target="_blank" style="color:#4f4f4ftext-decoration:none">Colored by Color Scripter

댓글