문제
N이 주어질 때, 다음과 같은 프로그램을 작성해보자.
입력
첫째 줄에 자연수 N이 주어진다.(1<=N<=100)
출력
예시를 참고하여 작성하자.
예제 입력
3
예제 출력
1 2 4 3 5 6
예제 입력
5
예제 출력
1 2 4 7 11 3 5 8 12 6 9 13 10 14 15
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
|
#include <stdio.h>
int main() {
int n;
scanf("%d",&n);
int arr[n][n];
int jStr = 1;
int jCount = 0;
int jSum = 0;
for(int i=0; i<n; i++){
jStr += jCount;
jSum = jStr;
arr[0][i] = jStr;
jCount++;
}
int Count = 2;
int iCount;
for(int i=1; i<n; i++){
iCount = Count;
for(int j=0; j<n-i; j++){
arr[i][j] = arr[i-1][j] + iCount;
iCount++;
}
Count++;
}
for(int i=0; i<n; i++){
for(int j=0; j<n-i; j++){
printf("%d ",arr[i][j]);
}
printf("\n");
}
return 0;
}
r
|
'[C++] 알고리즘 교육 > 1~4. 기본기' 카테고리의 다른 글
[알고리즘 3.1.2] 간단한 완전 탐색 - offset (0) | 2019.04.25 |
---|---|
[알고리즘 3.1.1] 간단한 완전 탐색 - car (0) | 2019.04.25 |
[알고리즘 2.2.10] 배열 - array2 (0) | 2019.04.23 |
[알고리즘 2.2.9] 배열 - array1 (0) | 2019.04.23 |
[알고리즘 2.2.8] 배열 - 숫자피라미드 (0) | 2019.04.23 |
댓글